GlassFish Console (4848) not loading

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

GlassFish Console (4848) not loading

sim085
This post has NOT been accepted by the mailing list yet.
Hello,

I have installed Glassfish4 on CentOs. All worked fine. However I noticed a problem. I used the command ./asadmin create-service to have GlassFish start on boot. When I restart, if I go to http://localhost/mywebsite mywebsite loads. If I go to http://localhost:4848 it looks like the console is trying to load but then I get a message that the website is not available.

I tried to look in logs /opt/oracle/glassfish4/glassfish/domains/domain1/logs/server.log However there is no entries from the GlassFish console. All I could find is entries from mywebsite.

I then used the command /etc/init.d/GlassFish_domain1 stop which prints "Command stop-domain executed successfully."

I then used the command /etc/init.d/GlassFish_domain1 start which prints an exception:

java.io.IOException: Couldn't get lock for /opt/oracle/glassfish4/glassfish/domains/domain1/logs/server.log
        at java.util.logging.FileHandler.openFiles(FileHandler.java:389)
        at java.util.logging.FileHandler.<init>(FileHandler.java:287)
        at com.sun.enterprise.admin.launcher.GFLauncherLogger.addLogFileHandler(GFLauncherLogger.java:98)
        at com.sun.enterprise.admin.launcher.GFLauncher.setup(GFLauncher.java:191)
        at com.sun.enterprise.admin.servermgmt.cli.StartDomainCommand.createLauncher(StartDomainCommand.java:220)
        at com.sun.enterprise.admin.servermgmt.cli.StartDomainCommand.executeCommand(StartDomainCommand.java:117)
        at com.sun.enterprise.admin.cli.CLICommand.execute(CLICommand.java:321)
        at com.sun.enterprise.admin.cli.AdminMain.executeCommand(AdminMain.java:360)
        at com.sun.enterprise.admin.cli.AdminMain.doMain(AdminMain.java:298)
        at com.sun.enterprise.admin.cli.AdminMain.main(AdminMain.java:206)
There is a process already using the admin port 4848 -- it probably is another instance of a GlassFish server.
Command start-domain failed.

Does anyone know what the problem might be? At the moment I am stuck without being able to re-deploy a new version of the application.
Loading...