Update of JAXB Maven plugins

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Update of JAXB Maven plugins

Marcel Valovy
Hi all,

I am notifying all JAXB maven plugin developers that new version of JAXB is out (2.2.11) and that some projects depend on new functionalities contained in JAXB 2.2.11. This makes developers unable to use JAXB maven plugins with such projects.

I would like to kindly ask JAXB maven plugin developers to update their plugins to use the newest version of JAXB.

Example bug in EclipseLink project:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=462508

Best Regards
Marcel Valovy
Reply | Threaded
Open this post in threaded view
|

Re: Update of JAXB Maven plugins

Mirko Klemm
Hi Marcel,
The jaxb2-rich-contract-plugin project (http://mklemm.github.io/jaxb2-rich-contract-plugin/), which adds fluent builders, copying, immutability etc. during XJC source generation is implemented against JAXB 2.2.11.
Also, the JAXB maven plugin org.jvnet.jaxb2.maven2:maven-jaxb2-plugin as of version 0.11.0 is working very well with JAXB 2.2.11
Regards,
Mirko

> Am 2015-04-01 um 11:17 schrieb Marcel Valovy <[hidden email]>:
>
> Hi all,
>
> I am notifying all JAXB maven plugin developers that new version of JAXB is out (2.2.11) and that some projects depend on new functionalities contained in JAXB 2.2.11. This makes developers unable to use JAXB maven plugins with such projects.
>
> I would like to kindly ask JAXB maven plugin developers to update their plugins to use the newest version of JAXB.
>
> Example bug in EclipseLink project:
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=462508
>
> Best Regards
> Marcel Valovy


smime.p7s (5K) Download Attachment